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1. Overview 

ScanIMAGER enables processing of 3D laser scan data. The software includes tools for processing 

point clouds obtained using various 3D laser scanning systems. The unique feature of the software is the 

capability to visualize a large amount of measurements as well as display the color of a measured point, which 

enables you to work with discrete data as a 3D model. 

Main features of the software are: 

 Upload scans containing billions of points (the number of files being uploaded simultaneously is 

restricted by the PC computing capacity) 

 Align (register) scans in a single coordinate system 

 Color point clouds using a set of digital images 

 Generate orthophotomaps reproduced on defined planes  

 Create planar views of convoluted surfaces 

 Take measurements using scans  

 Obtain object sections  

 Obtain part sections  

 Cut out fragments  

 Calculate areas and volumes  

 Export data to various formats (PTX, DXF, TXT) 

ScanIMAGER has been developed by Photogrammetria, a Russian research and production company 

based in St. Petersburg, since 2006 and is undergoing dynamic advancement now. The software has multiple 

editions. This manual describes Professional edition, which includes the widest set of features. Features that 

are unavailable in lower-level editions are marked with comments in brackets. For more information on 

ScanIMAGER and Photogrammetria, please visit our websites: www.scanimager.ru and 

www.photogrammetria.ru. 

 

2. Installation and Setup 

The software can be installed by running the installation file setup.exe that can be found on the 

installation CD or in the downloaded copy in the directory with the same name. Follow Installation Wizard 

instructions during installation. Please note: The software logs file operation history when working with scan 

data. Therefore, sufficient available disk space is required on the drive where the software is installed. 

 

3. PC Requirements 

Recommended configuration for working with the software is as follows: 

 Processor: Pentium Intel Core 2 Duo 2GHz or higher 

 RAM: 2 GB or more 

 Video card: based on mid-level nVidia or ATI Radeon chipsets 

 Additional requirements: network board (for network version) 

  

 

4. Operational Systems 

ScanIMAGER works in systems running Microsoft Windows XP, Microsoft Windows Vista, Windows 7, 

and Windows 8. Separate copies are available for 32-bit and 64-bit versions. 

http://www.scanimager.ru/
http://www.photogrammetria.ru/
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5. Definitions 

Point cloud (scan) is a graphic representation of a set of geometric objects each of which is 

represented by three space coordinates (X, Y, Z) and optical density. 

Orthophotomap is a raster image obtained by means of orthogonal projection of scan points 

onto the defined plane. Besides horizontal coordinates, an orthophotomap also contains data on the 

inner distance for each point. 

Planar view of a scan is a raster image obtained by projecting scan points onto the cylinder 

surface taking into account coordinates of the scan point. 

Project is a file containing a working set of scans. 

Scan registration is a process of aligning all scans into a single coordinate and height system 

selected by the user. 
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6. Working with ScanIMAGER 

6.1. General 

The software structure allows to work with data of different types (scans, orthophotomaps, planar 

views) in different modules within a single coordinate space. Each module’s functionality deals with a specific 

type of data and is represented in separate software tabs. 

 

6.2. Data Control Tab 

Data Control tab contains three modules: 

 Scan Manager module 

 Converting module 

 Registration module 

 

6.3. Data Control Tab Ribbon 

6.3.1. Scans 

Add — Adds scan files to the catalog. 
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Save — Saves changes to the current scan. 

Save All — Saves changes to all scans. 

Planar view — Creates a planar view of scans.  

Additional > Reset Registration — Deletes registration of the selected scans. 

6.3.2. Project 

New Project — Creates a new project file. 

Open Project — Opens a saved project. 

Save Project — Saves changes to a project. 

6.3.3. Converting 

Add task — Adds a conversion task. 

Delete task — Deletes a selected task. 

Clear tasks — Deletes all tasks. 

Settings — Opens Settings window for conversion. 

 

6.4. Scan Manager module 
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Scans Catalog section displays the list of uploaded SPF files. Information on the number or marks 

measured, registration and status is displayed for each scan. 

To show/hide a scan, click  in the View column. 

To set the color for scan points, click  in the Color column. Choose black to reset the selected 

color. 

Project information section displays information on the project. A software project is a working set of 

scans. It is not necessary to create a project before starting the work, you can create and save it after forming 

the scan set as well. 

  

6.5. Converting Module  

Converting module allows to convert point catalog files from 

exchange formats into the internal SPF format. To begin the 

converting, you need to create a converting task. Converting tasks 

are managed from Converting ribbon section. 

 

 

 

6.5.1. Creating a New Task 

Add task button opens Add task dialog box. 

Name for the task is entered in the Task name field. You can 

set a profile corresponding to the file format that needs to be 

converted in the Profile field. Units field allows to set units of 

measure for the file data. Click Add and select the necessary files 

to add files containing a set of points to the package. File must 

have the same format and correspond to the profile selected. In 

order to delete the files, select them in the list (multiple choice is 

allowed) and click Delete (or press the Delete key). 
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If the file being converted only contains points from one station and the station coordinates are known, 

these can be written in a .pos file with the same name in order X, Y, Z. During converting, the station 

coordinates will be read automatically from the created file and saved in SPF format for future use by some 

functions. If there is no file with station coordinates, clear the Check file with coordinates station checkbox. If 

the work was done using Faro Focus 3D scanner, you can use the registration report file instead of .pos files. 

Registration report file can be uploaded by clicking “...”. 

NOTE: In case of working with Faro Focus 3D using the Binary file of the directory of points (*.xyb) 

profile provides the best technological benefits. 

Hourglasses type marks can be recognized automatically during converting. To do this, you should 

enable the Find mark of given type option. 

 

6.5.2. Editing a Task 

To edit a task, double-click it in the Tasks list of the Converting module. The Edit Task dialog box will 

open which is similar to the Add task dialog box. 
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6.5.3. Converting Settings 

The Settings button in the Converting section opens the Settings dialog box. 

 

In this window you can specify one of existing file extensions or create a custom extension for each 

profile. The default profile that will be used for newly created tasks can be set in the Default profile field. 

Click Run to start the converting process. 
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6.6. Registration Module 

Registration module is used for registering (aligning) scans into a 

single coordinate system both manually and automatically. Recognized 

common marks or measured points are necessary for registration. Scans 

being registered must have at least three common marks/points for 

successful registration.  

 

6.6.1. Searching for Marks 

If marks were not recognized during converting, they can be 

measured manually on a flat view of a scan or automatically. 

For automatic recognition of marks on all scans click Recognize all 

in the Search marks section. To recognize marks on a single scan, you 

need to select the desired scan in the Scans Catalog section and click 

Recognized on the selected. 

Check Save marks to save marks to the hard drive automatically. 

The Check duplicates button is used to check whether the same mark is 

recognized twice. 

 

 

 

6.6.2. Block Registration 

Registering scans in a block allows for precise scan alignment into a 

local coordinate system of the first scan. 

Prior to registration, you must set tolerances for distance and 

relative altitude in the Options section so that corresponding marks are 

automatically defined in the desired units. The Boundary field contains 

the precision boundary. Values that are out of the boundary will be 

marked red.  

To register scans in a block, click Add block and enter the block 

name in the appearing dialog box. Then click Add scan and select the first 

scan from the appearing list to form a preliminary catalog for block 

points. The Catalog of block points dialog box will appear with block 

mark coordinates identical to mark coordinates of the first scan. 
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Then add scans as you go. After adding a new scan, the Calculate control dialog box will open. 

 

The Residual by points section contains residual errors for each point in units specified in the Options 

section of the Block registration scroll. If RMS and Maximum values fall within the tolerance, they appear in 

green, otherwise in red. Click the maximum value to move to the point with the maximum value in a 

coordinate. You can uncheck the point in the Points section to exclude it from calculation.  

If the Calculate control window is not displayed after adding a scan, it means that the software has not 

found three or more common marks between the block point catalog and the scan being added. 

After adding all scans to the block, click Registration in block. The Registration dialog box will appear 

with a table of data for each point in the block with residual error for each scan and maximum values. 
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To delete a scan from the block, select the scan in the Scans in block list and press the Delete key. To 

delete a block, select the block in the Blocks list and press the Delete key. 

IMPORTANT! All the block registration operations listed above can be automated. For automated 

registration simply click Autoregistration in blocks, after which all scans will be displayed in the Registration 

window with residual errors and maximum values. If the result of automated registration is unsatisfactory in 

terms of precision, registration should be done manually. For linking a scan block into the desired coordinate 

system, please refer to the next section. 

6.6.3. Transformation by the Base Points 
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In order to position separate scans or blocks in a geodesic coordinate system, a base point catalog must 

be uploaded (in the right coordinate system). To do this, click Basic points in the Transformation by the Base 

Points scroll. The Base points catalog section of the Geodesic measurements dialog box will display base 

points with their IDs. To exclude a point from calculation, click the rectangle with “+” symbol in the “+/-:” 

column. The excluded point will be marked with “-”. To find a mark in the catalog, enter the name in the 

Search mark field and press Enter. 

 

After uploading the points click one of the three buttons depending on the operation you want to 

perform: 

Block recalculation — Positions the current block selected in the Blocks list. 

Scans recalculation — Positions all scans without forming blocks in a geodesic coordinate system. For 

this operation, each scan should contain at least 3 geodesically measured base points. 

Blocks recalculation — Positions all formed blocks in a geodesic coordinate system. 
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6.7. Scans Tab 

The Scans tab is used to visualize and process laser scanning data represented in a point cloud. Features 

are listed in a ribbon and in the Control and Tools panels. 

 

 

6.8. Scans Tab Ribbon 

6.8.1. View Section 

Add View — Creates a new view. 

Settings of View — Configures current view (this feature is not available for standard views created by 

default, except for 3D view). 

Close View — Closes current view (this feature is not available for standard views created by default). 

Refresh — enforces screen redraw (the same can be done by pressing F5). 

 

6.8.2. Actions Section 

Export — Allows to export data to different exchange formats. Create Orthophotomap — Creates an 

orthophotomap and opens the ORTHO module. 
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Turn on the plane — Creates a planar view of convoluted objects (available in Standard and 

Professional editions). 

Colour Point Cloud — Colors the point cloud based on a set of aligned digital images (available in 

Professional edition). 

Copy Points — Creates a separate virtual scan and copies points within the selected region to it. 

Copy to AutoCAD — Copies points within a 3D limit box to AutoCAD system. 

Delete Points — Deletes points within the selected polygon. 

 

6.8.3. Additional Section 

Create Sections — Sets section parameters and starts the vectorization process (available in Standard 

and Professional editions). 

Correct Sections — Corrects the created sections (available in Standard and Professional editions). 

Delete Sections — Deletes the created sections. 

Filters > Scan Filtration — Starts the process of scan filtering in order to reduce the noise (available in 

Standard and Professional editions). 

 

6.8.4. Settings Section 

Grid — Displays and sets the grid parameters in XY plane. 

Settings — Opens the Settings window. 

 

6.9. Control Panel 

6.9.1. Settings 

View Quality — This setting corresponds to the number of points displayed on 

the screen. The higher the quality, the more points will be displayed.  

Detailed View — If this option is enabled, the display is redrawn after each 

action on the point cloud. If you work with a large amount of data, we recommend 

you to disable this option and use forced redraw by clicking Refresh in the View 

panel or pressing F5. 

Point Size — The size of point in pixels. 

Units — Units of measure in which point coordinates in the information panel 

are displayed. These are also units in which points are exported! 
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6.9.2. Intensity Regulation 

Tools in this panel allow to adjust screen brightness and contrast (only for points that have reflected 

signal intensity rather than a real color obtained by coloration based on aligned images). Select the scan to 

which the settings will apply in the Active Scan field. The Min and Max fields are used for lower and upper 

limits of intensity range (0 to 10,000) respectively. Intensity within these limits is converted to grayscale (55 to 

255). Increasing or decreasing brightness with “+” and “–“ buttons shifts the range limits. Increasing or 

decreasing contrast with “+” and “–“ buttons narrows or broadens the limits respectively. You can also set 

range limits explicitly. 

 

6.9.3. Scan Registration 

ScanIMAGER provides several scan registration methods: based on 

tacheometric survey data, relative to another scan and based on set parameters. 

The first two methods of scan alignment can be applied both to special marks 

and arbitrary points of the object being scanned. 

Hourglass marks (ZF marks) are the most common in the field of laser 

scanning. This type of mark provides high precision both when determining its 

coordinates using a scan and during targeting in the process of tacheometric 

survey.  

Photogrammetric marks are used for special tasks that require the 

algorithm developed by Photogrammetria experts. This type of mark provides 

high precision of measurements based both on scans and on digital images. 

Spot point is an arbitrary mark, its coordinates are determined by 

averaging measurements that fall within the given area. This type of mark is 

useful to calculate projection rotation angle when creating an orthophotomap in 

case the object is not parallel to any of the standard views. It can also be used for 

scan alignment based on distinctive points of the object, i.e. window angles, but 

this way is less precise and more time-consuming and thus rarely used in practice. 

 

6.9.3.1. Scan Registration Based on Tacheometric Survey Data 

To register scans using tacheometric survey data: 

 Open the scans you want to register. 

 Click  (Import Mark Catalog) in the Scan Registration 

panel. Select a file with mark coordinates in the appearing dialog box. This 

should be a TXT file consisting of four columns, the first column being the mark 

number and the second, the third and the fourth columns containing X, Y, and 

Z coordinates respectively. 

 Select mark type and size in the Import Marks window.  

ZF mark 

Photogrammetric mark 
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 Imported marks and their coordinates will be displayed in the Catalog of Points, and the 

Geodata status will change to Measured. 

 Then specify the marks on the scan being registered. To do this: 

o Select the tab with the corresponding scan number in the panel of scans. 

o Select the mark being determined in the Catalog of Points and point it on the scan.  

o The Select Mark dialog box will appear. It will display mark number and coordinates as 

well as the name of the scan to which it belongs, and a graphic representation of the mark to control rough 

inaccuracies during measurements. 

 

After confirming the measurement in the Mark Catalog in the column of the selected scan, 

the mark status will change to Measured. Follow the same procedure to point all other marks on each scan, 

after which registration can be performed. 

 To register a scan, click  (Scan Registration...) in the Scan Registration panel. The Scan 

Registration dialog box will appear. Select the scan to register and specify the transformations to be 

performed during the registration. If the registration is related to a coordinate file, select None for Base scan. 
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Calculation RMS will be displayed at the bottom of the Scan Registration window. After you click 

Register, the main view will be refreshed and the status of the registered scan in the Scan Manager module 

will change to CHANGED. Click Save changes to save the registration. 

 

6.9.3.2. Registration Relative to Another Scan 

To register a scan in relation to another (base) scan: 

 Open the base scan and the scan to register. 

 Select the base scan in the panel of scans and point marks on it. To do this, click  (Create 

mark) in the Tools panel. Specify the number, type and size of the mark in the dialog box. Then point the mark 

on the scan. Follow the same procedure to measure the other marks. 

 After pointing all marks on the base scan, select the scan you want to register in the panel of 

scans. 

 Point the created marks on the scan being registered. 

 Select the base scan in the Scan Registration panel and click  (Scan Registration...). The rest 

of the procedure is identical to registration based on tacheometric survey data. 

6.9.3.3. Registration Based on Set Parameters 
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Registration based on set parameters is performed without using marks. This method is used in case 

transformation parameters are known. After clicking  (Scan Registration...) select Rotation By Given Angles 

in the appearing dialog box and enter their values manually. Then click  to calculate the transformation 

matrix. The rest of the procedure is identical to registration based on tacheometric survey data. 

6.9.3.4. Additional Tools 

 — Delete Mark — Deletes the selected mark. 

 — Delete All Marks — Deletes the whole mark catalog. 

 — Delete Mark Measurement — Only deletes the measured coordinates of the selected mark. 

 — Delete Measurements of All Marks — Only deletes the measured coordinates of all marks. 

 — Default Mark Setting — Opens the window for setting the parameters of the default mark. 

 — Export Mark Catalog — Exports the coordinates of the marks measured on the scan into a text 

file. 

 — Reset Registration— Deletes all registration data from the scan.
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6.10. Tools Panel 

6.10.1. Limit boxes 

Tools in this panel allow to create 3D limit boxes and flat regions.  

A 3D limit box is used for limiting the scan to a desired 3D area. 

These restrictions affect point display (if Show Only Inner Points is 

enabled) and how points participate in different processes (cutting, 

export, creation of an orthophotomap, etc.). To create a 3D limit box, 

Click  (Create Limit Box) (limit box borders correspond to the scan 

borders by default). A 3D limit box can be set by entering direct values 

into the corresponding fields (X min, X max, Y min, Y max, Z min, Z max) 

or by moving the borders using the mouse in standard views (except for 

3D view). You can save or upload a previously created limit box using the 

 (Save Limit Box) and  (Open Limit Box) buttons. Click  (Delete 

Limit Box) to delete the limit box. 

A region allows to set an area (in the screen plane) of points that 

will be used for deletion and copying. To create a region, click  (Create 

Region) and draw it on the screen by adding vertices by means of left-

clicking (if the Projection parameter of the current view was set to 

Perspective, it will change to Orthographic). Press Escape to cancel 

further vertex addition. Click Create Region again to delete a previously 

created region. Press Escape to cancel drawing of the region. 

 

 

 

 

6.10.2. Measuring 

The Measuring panel is used for measuring segments or paths between scan points. To measure a 

distance, select the Type of measurement (Segment or Path), click Measure and specify the scan points 

between which the distance needs to be measured. The result is displayed in the Length field. 

 

6.10.3. History 

ScanIMAGER includes a tool for registering and saving changes made to scans in an action history. The 

following actions on scans are logged: 

 Point deletion 
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 Coloration 

 Filtering 

 Conversion (registration) 

Each of the actions listed above is logged in the Actions list. To cancel one or more actions and return to 

a previous state, select the action you want to return to in the list and click Apply. 

 

6.11. Main Features of Scans Tab 

6.11.1. Add view 

The Add view button in the View panel opens the View dialog box. To create a new view, enter the 

necessary parameters (see Section 6.11.2) and click OK. 

 

6.11.2. Settings of View 

To configure the current view (except for 

standard views parallel to the corresponding planes), 

click Settings of View in the View panel (or click 

Settings of View... in the context menu that can be 

opened by right-clicking Coordinate Space Field). Set 

the necessary parameters in the View dialog box that 

will open and click OK. 

 

There are the following view settings: 

 View name 

 View type (2D view or 3D view). 

Rotation is not allowed for 2D views. 

 View projection (orthographic or 

perspective). It is possible to create an orthophotomap 

from the current view in case of orthographic projection only. 

 View orientation. A view can be oriented perpendicular to one of the standard planes, or 

orientation angles can be set arbitrarily. You can also orient a view perpendicular to an arbitrary plane. To do 

this, specify at least 3 spot point type marks on an arbitrary plane (see Section 6.9.3), and plane parameters 

and orientation angles will be calculated after you click By Marks. 
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6.11.3. Export 

The Export button in the Actions panel opens 

Save As dialog box where you can select the output 

file format. After you specify the file name, the   

Export dialog box will open with various settings 

depending on the format: 

 Subsample — Sets the interval for 

writing points to the file (“1” means 

every point is written). 

 Precision — Number of decimal places. 

 Use resolution — Writes points to the 

file with the specified resolution (allows to obtain a more uniform subsampling), blocks the 

Subsample setting. 

o Average data — Averages the data by all points that fall within the cell with the given 

resolution. 

o Take the first measurement — Uses the first measurement that falls within the cell with the 

given resolution; other values within the cell are ignored. 

 Settings... — Allows to select the type of representation for color information: 

o RGB color 

o Intensity ranging from 0 to 1.0 

o Intensity ranging from 0 to 255 

 

6.11.4. Create Orthophotomap 

Before creating an orthophotomap: 

 Limit the points that will be used for creating an orthophotomap using a 3D limit box (see 

Section 6.10.1) if necessary. 

 Select the projection plane. To do this, choose one of the standard views or create a new 

one by setting the required plane parameters (see Section 6.11.2). 

Click Create Orthophotomap in the Actions panel to create an orthophotomap. 
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The Projection dialog box will open. Set the following parameters: 

 Range — Sets the range for projection (Limit Box or Scan). Limit Box is selected automatically in 

case a 3D limit box is specified. 

 Scale — Sets the resolution for the projected orthophotomap (mm per pixel). 

 You can correct the projection borders in the corresponding fields. Information on the size of the 

resulting orthophotomap is given below. 

 Use Actual Size — Enables the field for setting actual scale (mm per pixel). If the resolution of the 

orthophotomap being created is higher than scan resolution, it may result in back points showing 

through the front ones. In this case enabling this option and setting actual scan resolution can 

solve the problem. 

 Intensity Correction — Enables reflected signal intensity levelling (based on the set polynom) 

when multiple scans are used for the same area. This reduces the color noise effect. 

 By scan position — Divides the orthophotomap into areas around scanner position points, and 

these areas are filled with points from the nearest scan only. This increases the image quality due 

to absence of noise from other scans. This option is used for almost flat objects. 

Click Create to start the point projection process. After completing the projection, further actions are 

performed on the Orthophotomaps tab (see Section 7). 
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6.11.5. Turn on the plane 

In order to create a development of a convoluted object, first 

you need to specify spot point type marks on the object one by one 

(see Section 6.9.3). Mark size is chosen depending on the scan 

resolution and noise level (mark size should be approximately 2 or 3 

times greater than scanning pitch). The beginning of the 

development is formed by the coordinates of the first mark, and the 

coordinates of the last mark are the end. Marks should be specified 

sequentially, a new mark cannot be added between the two 

previously specified marks! After that, click Turn on the plane in the 

Actions panel and specify the projection in the Select Projection window that will open. 

 

6.11.5.1. Projection on the cylinder 

The Projection on the cylinder dialog box will open. You 

can set the range (Limit Box or Scan), choose the scale, the 

projection plane (XY, XZ, YZ) and the acceptable deviation in the 

Projection Parameters section. The lower the acceptable 

deviations from the circle, the more circles are used for 

approximation of the given curve. The Circle is closed option 

closes the set of the specified marks with the first mark. If you 

change the above mentioned settings, the size of the resulting 

orthophotomap is recalculated automatically. Specify the number 

of circles used for approximation of the curve formed by the 

specified points, in the Quantity of circles field. The calculated 

length is displayed in the Planar view length field. The Residual 

section displays deviations from the circle for each point as well 

as average and maximum values for the selected point. The 

resulting development is displayed in the Orthophotomaps tab. 
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6.11.6. Colour Point Cloud 

To color a point cloud using oriented digital images, click Colour Point Cloud in the Actions panel.  

 

Make a list of processed images and enable corresponding options in the Create Coloured Scan dialog 

box that will open. To add images to the list as projects created in the Orthophotomaps tab or in 

PhotoTransformator software (http://www.photogrammetria.ru/6-phototransformator.html), click Add and 

select the necessary folders where project with images are located. For the correct scan coloration, the images 

must be taken from the scan point. Simultaneous coloration of point clouds obtained from different scan 

points is not allowed. The Keep Grayscale Points option prohibits deletion of uncolored points during 

coloration. The Use Scanner Optical Density Chanel option allows to color the scan using YCbCr color space 

(brightness, red-difference and blue-difference chroma components) which uses scanner brightness channel 

instead of image brightness channel and thus maintains the sharpness of the initial scan. The Use defined 

indent option allows to reduce the area of the image that is used for scan coloration by setting a fixed offset 

from the image edges (in pixels). Black (RGB 0/0/0) on the images is ignored during coloration. 

 

6.11.7. Create Sections 

To create long- and cross-sections of an object, click Sections > Create 

Sections. 

In the opened dialog box, specify which sections you want to create, 

set the region (Limit Box is selected automatically in case a 3D limit box was 

created), Step (in meters) and precision (calculated automatically based on 

the previous setting). The most successfully drawn up sections are ones 

where the object is mostly located in XY plane without dramatic differences 

in height and curves (banks, open pits, roofs etc.). 

http://www.photogrammetria.ru/6-phototransformator.html


28 
 

 

6.11.8. Correction of Sections 

To correct “shots” in the created sections, click Sections > Correct 

Sections. 

Set the following parameters in the opened dialog box: Number of 

“Shots” — corresponds to the number of vertices involved in the “shot”, 

and “Shot” Length — corresponds to the acuteness of the “shot” angle 

(the lower the value, the more obtuse angles between two vertices are 

considered a “shot”). Changes in parameters lead to automatic redraw.  

 

 

6.11.9. Volume by Sections 

To calculate the volume based on sections, click Sections > Volume by 

Sections. 

In the opened dialog box, set Direction (Up means positive volume, 

e.g. bank, Down means negative volume, e.g. an open pit), and enter the 

height point from which the volume will be calculated in the specified 

direction in the Slice Level field. Calculation result will be displayed in the 

corresponding fields after clicking Calculate. 

 

 

 

 

6.11.10. Scan Filtration 

To start the scan filtering process, click Filters > Scan Filtration. 

 

Enter the following parameters in the opened dialog box: 

 Cell size — corresponds to the size of the cube facet (cell) 

into which the scan is divided. 

 Filter Threshold — corresponds to the minimum amount of 

points in a cell. If the number of points that fall within a cell 

is lower than the specified threshold, all points in the cell 

are deleted. 
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6.11.11. Grid 

When you click Grid in the Actions panel, the Grid dialog box will 

open where you can enable or disable displaying the grid as well as set 

its color and step (in meters). The grid is displayed in XY plane at the 

lower border of the point cloud. 

 

 

 

 

6.11.12.  Settings 

Click Settings in the main menu to open the software settings. The left part of the Settings window 

contains sections and the right part displays the corresponding settings. 

 

6.11.12.1. General Settings Section 

 

6.11.12.1.1. View Settings. You can set the type for the default 3D view that will be assigned to the 

view at the software start. 

6.11.12.1.2. History settings. Maximum size of the action buffer is set here. 

6.11.12.1.3. Screen Redraw. Enables constant refreshing of the screen. ATTENTION: The image may 

blink if this option is enabled on computers with video boards not supporting double buffering. In this case 

disable the option. 
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6.11.12.2. Object Settings Section 

 

6.11.12.2.1. Mark. Sets the type and size for the default mark as well as colors for active and 

passive marks. 

6.11.12.2.2. Limit Box. This option enables saving the specified 3D limit box after closing all scans.  

 

6.11.12.3. Path Settings Section 

This section allows to set the path for oriented images used for coloration of scans created in the 

Orthophotomaps tab or PhotoTransformator software (http://www.photogrammetria.ru/6-

phototransformator.html). 

 

 

 

http://www.photogrammetria.ru/6-phototransformator.html
http://www.photogrammetria.ru/6-phototransformator.html
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7. ScanIMAGER Ortho Module 

7.1. General 

ScanIMAGER Ortho Module is designed to work with orthophotomaps projected on a specified plane. 

You can work with multiple orthophotomaps in this software and switch between them using tabs in the main 

panel. You can also upload multiple orthophotomaps simultaneously in the same tab (they need to have the 

same size and recalculation parameters for the coordinate system), and they will be combined into one during 

upload. The software uses internal *.spo format to store orthophotomaps. Besides plan coordinates and 

information on color, this format also contains data on the third coordinate making it a 3D orthophotomap. 

 

7.2. The Main Window 

 

7.3. Main Menu 

7.3.1. File 

Open Ortho — Uploads one or more selected orthophotomaps (each in a separate tab). 

Open and Combine — Uploads multiple orthophotomaps with the same parameters and combines 

them into one. 

Save Ortho — Saves the current orthophotomap. 

Close Current — Closes the current orthophotomap. 
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Close All — Closes all uploaded orthophotomaps. 

Converting — Converts orthophotomaps from old *.spo format to new. 

Control of images — Opens the Control of images dialog box that allows to work with a list of image 

projects. 

Export Image — Exports the orthophotomap into graphic formats (*.tiff, *.jpg, *.bmp) or a point cloud. 

Export to AutoCAD — Exports the current orthophotomap into a *.dwg file as a raster image with 

recalculation for the working coordinate system. 

 

7.3.2. Actions 

Delete Points — Deletes points inside the specified region. 

Crop — Cuts the orthophotomap by the given border. 

Interpolation — Starts the interpolation process which eliminates blanks in the orthophotomap. 

Create Coloured Orthophotomap — Colors the orthophotomap using a set of oriented digital images 

(available in Professional edition). 

Calculate square — A tool for calculating the surface area by an orthophotomap. 

Specify Base Points — Opens the panel for specifying base points to calculate external orientation 

elements. 

Highlight Images — Enables highlight mode for a part of colored orthophotomap. 

Grid — Displays and sets the coordinate grid parameters in the orthophotomap plane. 

 

7.3.3. Filters 

Noise Correction — Starts orthophotomap correction process in order to eliminate isolated points and 

local “shots”. 

Smooth/Blur — Starts smoothing the current orthophotomap by reflection intensity and inner distance 

in each point. 

Pseudocolouring — Used for clearer contour definition.  

Segmentation — Used for clearer contour definition. 

Subtraction — Subtracts one orthophotomap from another using the inner distance coordinate. 

Negative Image — Reverses the reflection intensity parameter. 

Change Channels — Swaps RGB channels for pseudocolored and colored orthophotomaps. 

 

7.3.4. Settings 

Opens the setting window. 

7.3.5. About 
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opens a window with information on the software and license. 

  

7.4. Context Menu 

Can be opened by right-clicking the image panel. 

Fit to the Window — Scales the orthophotomap so that the whole image fits within the window. 

Actual Size — Scales the orthophotomap so that each pixel of an orthophotomap corresponds to one 

pixel of the display. 

Region — Contains commands used for creating and deleting regions. 
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7.5. Main Features 

7.5.1. Delete Points  

To delete points, set the region (see Section 7.5.8) and click Actions > Delete Points. 

 

7.5.2. Crop  

To crop (cut) an orthophotomap, set the required region (see Section 7.5.8) and click Actions > Crop. 

 

7.5.3. Interpolation 

To start the interpolation process, click Actions > Interpolation. 

In the opened dialog box, set the filter cell size and interpolation 

range (Ortho or Region). The Multi Process option enables continuous 

interpolation until there is no point to interpolate in the specified cell 

size. The Full Process option enables continuous sequential 

interpolation within the cell sizes specified in the Cell Size and Limit Cell 

Size fields respectively. 

 

 

 

Filtering results: 
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7.5.4. Calculate Square 

To calculate the surface area by an orthophotomap, points within the selected region or all 

orthophotomap points (in case there is no orthophotomap) are used.  After the calculation process is 

complete, a reporting window is displayed with the following calculation results: surface base area, surface 

areas calculated with two methods and arithmetic mean of these two results. You can select the units of 

measure in which the results will be displayed. 

 

7.5.5. Grid  

When you click Actions > Grid, the Grid dialog box will open where you can enable or disable displaying 

the grid as well as set its color and step (in meters). 

 

 

 

7.5.6. Filters 

7.5.6.1. Noise Correction 

To start the noise elimination process, click Actions > Noise Correction. The filter eliminates both 

isolated points and local “shots” on the orthophotomap. 
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 To eliminate isolated points, enable Delete Separate Points and set the following filter parameters: 

 Radius of Search — Corresponds to the size of the region (in pixels) where points are counted. 

 Number of Points — Corresponds to the minimum number of points in the region. If the number 

of points in the area around the “suspicions” point with the specified radius is lower than allowed, 

the “suspicions” point is deleted. 

To eliminate local “shots” (orthophotomap points with Z coordinate significantly different from the 

neighboring points), enable Delete “Shots”. Set the number of sequential points that will be interpreted as a 

local “shot” in the Number of Correction Points field. 

7.5.6.2. Smooth/Blur  

Smoothes the inner distance coordinate (perpendicular to the screen plane) and reflection intensity.  Set 

smooth factor and application range (Orthophotomap or Region) in the Inner Distance Smooth window. 

 

7.5.6.3. Pseudocolouring 

To pseudo-color an orthophotomap for clearer contour definition, click Filters > Pseudocolouring. 
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Set the application scale of the color space in the opened Pseudocolouring dialog box. If the scale is set 

to 1.0, the color space is used without repetition within 1 meter of inner distance. It is recommended to 

increase the scale if there are small differences, and decrease the scale if differences are significant. 

Example of the feature use: 

 

 

 

 

 

 

 

 

Brightness channel of the orthophotomap is used in pseudocolouring by default. To obtain a colored 

image without brightness channel, enable Define General Brightness and specify the value from 0 to 255 in 

the corresponding field. 

7.5.6.4. Segmentation  

Segmentation is used to highlight contours on the 

orthophotomap.  To segment the image, click Filters > Segmentation. 

Set Blur matrix size, Blur coefficient and Tangent coefficient in 

the Select contour dialog box. The values depend on the 

orthophotomap resolution and source data quality. Applying this filter 

results in a black-and-white image with clear contours. Inner distance 

coordinate is used to generate this image while reflection intensity in 

each orthophotomap point is ignored. If Invert the image is disabled, 

the result will be a negative image (with black background). 
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An example of image segmentation: 

 

 

7.5.6.5. Subtraction 

 Subtracts an orthophotomap selected in a file from the current orthophotomap. To perform this 

operation, the sizes of orthophotomaps must be identical. 

7.5.6.6. Negative Image  

Inverts the colors of the active orthophotomap. 

7.5.6.7. Change Channels  

 Swaps the R and B channels in the RGB color space. 

 

 

7.5.7. Settings 

Click Settings in the main menu to open the module settings.  

 

7.5.7.1. Mark properties: Sets the width and color of the mouse pointer. 
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7.5.7.2. Colors: Sets colors for various objects and areas of the module. 

7.5.7.3. Grid: Sets the step and (default) color of the grid, as well as parameters for size, color and 

labels of the grid in the exported image. To save the grid to a file (when exporting to a raster image), enable 

Save grid in file and set the required parameters. 

7.5.7.4. Camera Directory Path  In the Path settings section, set the path to the folder with files 

containing information on camera calibration (internal image orientation elements for orthophotomap 

coloration).  

 

7.5.8. Region Control 

To create a rectangular area, open the context menu (right-click the image panel), click Region > Create 

Rectangle, and point the upper left and bottom right corners of the area on the image. 

To create a polygonal area, open the context menu (right-click the image panel), click Region > Create 

Polygon, and point the vertices of the polygon on the image. To cancel the command and finish region 

creation, press Escape. 

To delete the region, click Region > Delete Region. 

 

 

 

7.5.9. Create Coloured Orthophotomap 

A colored orthophotomap results from coloring a black-and-white orthophotomap by mapping each 

orthophotomap point to a corresponding point of a digital image.   

Creating a colored orthophotomap consists of the following main steps: 

 Creating a black-and-white orthophotomap 

 Forming an image catalog 

 Calculating internal elements for image orientation 

 Coloring the orthophotomap 

 Highlighting the images 

7.5.9.1. Creating a black-and-white orthophotomap 

A black-and-white orthophotomap is created in the ScanIMAGER module, followed by processing and 

filtering in the ScanIMAGER Ortho module (see subsections 6.7.6, 7.5.1 – 7.5.9).  

7.5.9.2. Forming an image catalog 

To create an image catalog, click File > Control of images or press Ctrl + M. 
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In the Control of images dialog box, specify the path to the directory containing image projects. The 

directory can contain projects created in PhotoTransformator.   If there are no projects, specify an empty 

directory and create projects using the project creation button .  

File of the catalog of base points can be specified manually, 

otherwise it is created automatically. 

To create a project, specify the path to the .JPG, .BMP or .TIF 

image file in the Creation of the project of an image dialog box.  

Enter the project name in the corresponding field. The project name 

corresponds to the digital image file name by default. 

Then select the camera and the assembly used for 

photographic work from the camera catalog.  You can also turn the 

image by a multiple of 90° to simplify future processing. The View 

button allows to preview the image as it would be uploaded to the 

new project. 

After creating an image project it will appear in the image list. 

The image line color represents its status: grey — an active image, 

red — an image with no external orientation elements calculated, 

green — an image with external orientation elements calculated. 

External orientation elements of the image must be calculated 

for orthophotomap to be colored. 

Use  buttons to expand and minimize the image list. 

Use  buttons to delete one or all images in the list. 
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Click OK or close the dialog box to finish image list creation. You can continue to form the image list any 

time by clicking the corresponding command in the File menu. 

7.5.9.3. Calculating External Image Orientation Elements 

To calculate external orientation elements for images, click Actions > Specify Base Points.  Image panel, 

base point catalog and control panel will open in the main window of the module. 

The Control panel displays the list of images.  The active image is displayed in the image panel. 

Calculation of external orientation elements consists if the following steps: 

 Forming the base point catalog 

  Measuring and adjusting base point positions on the image 

 Calculating the orientation elements 

To calculate external orientation elements, we recommend to measure at least five points on the image 

with at least one base point per each quarter. 

 

Forming the Base Point Catalog 

 

To add a point to the base point catalog, point it on the orthophotomap and enter its name in the 

opened dialog box. The point with coordinates in the orthophotomap coordinate system will be displayed in 

the base point catalog at the bottom of the screen. 

Point measurement 

To measure the coordinates of an image point, select the point in the Measured points list, place the 

mouse pointer at the corresponding place on the image and click  (Measure).  

To change the point coordinates, select the point in the Measured points list or double-click a measured 

point on the image, place the mouse pointer to the new place in the image and click  (Move).  

To delete the point measurement, select the point in the list and click  (Delete Measurement). 
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You can also delete all base points measurements by clicking  (Delete All Measurements). 

You can also upload base points from a text file using the  (Open Catalog) button in the Base points 

tab of the Control panel. There is also a button for saving base points in a text file —  (Save Catalog). 

In case projects for orthophotomap coloration were created in PhotoTransformator, they are uploaded 

to the ScanIMAGER Ortho module with pre-calculated external orientation elements and point catalog. 

ScanIMAGER Orthomodule has a feature for automatic creation of the base point catalog which can be applied 

by clicking  (Synchronize).  The software reads the points from project files and writes them to a single file 

with new unique names.   

Orientation Element Calculation 

To calculate external point orientation elements, click  (Orientation Elements) of the Images panel. 

Preliminary values for orientation elements are calculated in the Preparation for calculation of 

orientation elements dialog box. Here you can also select elements to define. 

 

Inner image orientation elements (focal distance and zero distortion point coordinates) are uploaded 

automatically according to the camera selected during project creation. 

To begin the process of levelling and orientation element definition, click Calculate. 

Click the Start button in the Calculation of elements dialog box to begin the levelling process, upon 

completion save the results by clicking Save.  The Information on points field will display data on residual 

errors on X and Y. If the elements were calculated successfully, you can evaluate the precision after saving by 

clicking  (Precision). 
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7.5.9.4. Coloring the orthophotomap 

Click Actions > Create Coloured Orthophotomap to open the Create Coloured Orthophotomap dialog 

box. 

 

To the left of the opened dialog box the image list is displayed, and the right part contains image 

preview and coloration options. 

In the image list, tick the images you want to use for coloration of the current orthophotomap. 
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The following options are available for creating a colored orthophotomap: 

 Photos Are Taken From Scanner Position — Used in case scanner position point coordinates 

match shooting point coordinates 

 Keep Grayscale Points — When using this option, points not covered by images are included in the 

result as grayscale points 

 Use Scanner Optical Density Chanel — Allows to color the orthophotomap using YCbCr color 

space (brightness, red-difference and blue-difference chroma components) which uses scanner 

brightness channel instead of image brightness channel and thus maintains the sharpness of the 

source scan 

 Use defined indent — Allows to reduce the area of the image that is used for scan coloration by 

setting a fixed offset from the image edges (in pixels) 

 Use transformed image — Is used for projects calculated in PhotoTransformator in case the 

project contains a transformed image (a digital image with eliminated perspective distortion) 

 Use transform region — Only points within special areas defined in PhotoTransformator are used 

for coloration 

 Color Smoothing — Allows to smooth major color 

differences at image edges when coloring an 

orthophotomap using multiple images. Black (RGB 0/0/0) 

on the images is ignored during coloration. 

       By clicking the Settings button you can: 

o select grid step (the size of smoothing matrix in 

pixels)  

o select the polynom degree  

o apply edge smoothing option   

o set border size (offset from each edge of the image 

limiting the area that will be used for edge 

smoothing) 
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ScanIMAGER Ortho Module provides preview during coloration, which allows to evaluate the 

quality of coloration with selected settings. Preview factor is set in the Create coloured 

orthophotomap dialog box and affects how much the preview will be reduced in size 

relative to the original orthophotomap (the higher the factor, the lower the preview 

resolution). 

Full-size orthophotomap coloration is performed by clicking Run.  Coloration result is displayed 

in the main window of the application. 

7.5.9.5. Highlighting the Images 

After coloration you can use Actions > Highlight Images to evaluate the result.  The software will display 

the colored orthophotomap and the Image Highlighting panel containing the image list. The area colored using 

the image selected in the list is highlighted, which allows to evaluate image borders, stitching quality and color 

levelling. 


